InitialWattageIntensity Constructor (Double, Double)


Initial Wattage Intensity(Double, Double) Constructor

Creates an initial wattage intensity object with the given values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public InitialWattageIntensity(
	double efficacy,
	double wattage
)

Parameters

efficacy Double
The universal unit efficacy value as a numerical value between 0 and 1e+30.
wattage Double
The universal unit wattage value as a numerical value between 0 and 1e+30.
Exceptions
Exception Condition
ArgumentOutOfRangeException The efficacy value is not valid because it is not between 0 and 1e+30. -or- The wattage value is not valid because it is not between 0 and 1e+30.
See Also