Replaces all filters in this ScheduleDefinition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- filters
- Type: System.Collections.GenericIListScheduleFilter
The new list of filters.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The resulting filter count would be greater than 8. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field and filter type cannot be used to filter this ScheduleDefinition. -or- A filter value is not valid for the field and filter type. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This ScheduleDefinition does not support filters. |