SetFilters Method


Schedule Definition Set Filters Method

Replaces all filters in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetFilters(
	IList<ScheduleFilter> filters
)

Parameters

filters IList ScheduleFilter
The new list of filters.
Exceptions
Exception Condition
ArgumentException The resulting filter count would be greater than 8. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field and filter type cannot be used to filter this ScheduleDefinition. -or- A filter value is not valid for the field and filter type.
ArgumentNullException A non-optional argument was null
InvalidOperationException This ScheduleDefinition does not support filters.
See Also