GetActiveServerId Method (Document)


Returns the Id of the server currently associated with the given document for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public Guid GetActiveServerId(
	Document document
)
Visual Basic
Public Function GetActiveServerId ( _
	document As Document _
) As Guid
Visual C++
public:
Guid GetActiveServerId(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document for which the server is being set as active.

Return Value

The Guid of the active server, or an invalid Guid if there is no active server assigned.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also