GetActiveServerId Method (Document)


Single Server Service Get Active Server Id(Document) Method

Returns the Id of the server currently associated with the given document for the service.

Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public Guid GetActiveServerId(
	Document document
)

Parameters

document Document
The document for which the server is being set as active.

Return Value

Guid
The Guid of the active server, or an invalid Guid if there is no active server assigned.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also