InitialFluxIntensity Constructor (Double)


Creates an initial flux intensity object with the given document and flux values.

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public InitialFluxIntensity(
	double flux
)
Visual Basic
Public Sub New ( _
	flux As Double _
)
Visual C++
public:
InitialFluxIntensity(
	double flux
)

Parameters

flux
Type: SystemDouble
The flux value in lm as a numerical value between 0 and 1e+30.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The flux intensity value is not valid because it is not between 0 and 1e+30.

See Also