Creates a slab edge along a reference.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- SlabEdgeType
- Type: Autodesk.Revit.DBSlabEdgeType
The type of the slab edge to create
- reference
- Type: Autodesk.Revit.DBReference
A planar line or arc that represents the place where you want to place the slab edge.
Return Value
If successful a new slab edge object within the project, otherwise a null reference (Nothing in Visual Basic).Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown if the slab edge type does not exist in the given document. |