NewSlabEdge Method (SlabEdgeType, Reference)


Document New Slab Edge(Slab Edge Type, Reference) Method

Creates a slab edge along a reference.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public SlabEdge NewSlabEdge(
	SlabEdgeType SlabEdgeType,
	Reference reference
)

Parameters

SlabEdgeType SlabEdgeType
The type of the slab edge to create
reference Reference
A planar line or arc that represents the place where you want to place the slab edge.

Return Value

SlabEdge
If successful a new slab edge object within the project, otherwise .
Exceptions
Exception Condition
ArgumentException Thrown if the slab edge type does not exist in the given document.
See Also