GetRectangularWidth Method


Returns the width of a curve loop if it is rectangular with respect to the projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public double GetRectangularWidth(
	Plane plane
)
Visual Basic
Public Function GetRectangularWidth ( _
	plane As Plane _
) As Double
Visual C++
public:
double GetRectangularWidth(
	Plane^ plane
)

Parameters

plane
Type: Autodesk.Revit.DBPlane
The plane to which the curves will be projected.

Return Value

The width.

Remarks

The width is determined by the U extents of the UV curve created by from the curve loop plane.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The curve loop is not rectangular when projected to the input plane.

See Also