GetRectangularWidth Method


Curve Loop Get Rectangular Width Method

Returns the width of a curve loop if it is rectangular with respect to the projection plane.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetRectangularWidth(
	Plane plane
)

Parameters

plane Plane
The plane to which the curves will be projected.

Return Value

Double
The width.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException The curve loop is not rectangular when projected to the input plane.
Remarks
The width is determined by the U extents of the UV curve created by from the curve loop plane.
See Also