Inserts a new ConduitSize in to the conduit size settings. The conduit standard name determines the location of the new size in the size table.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- standardName
- Type: SystemString
The conduit standard name.
- sizeInfo
- Type: Autodesk.Revit.DB.ElectricalConduitSize
The new ConduitSize to be added.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The conduit standard name does not exist. -or- The conduit size already exists. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The function is called during iterating the size set. |