Conduit |
Inserts a new ConduitSize in to the conduit size settings. The conduit standard name determines the location of the new size in the size table.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- standardName String
- The conduit standard name.
- sizeInfo ConduitSize
- The new ConduitSize to be added.

Exception | Condition |
---|---|
ArgumentException | The conduit standard name does not exist. -or- The conduit size already exists. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | The function is called during iterating the size set. |