SetSystemType Method


Updates the associated system type for the pipe.

Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public void SetSystemType(
	ElementId systemTypeId
)
Visual Basic
Public Sub SetSystemType ( _
	systemTypeId As ElementId _
)
Visual C++
public:
void SetSystemType(
	ElementId^ systemTypeId
)

Parameters

systemTypeId
Type: Autodesk.Revit.DBElementId
The ElementId of the piping system type.

Remarks

If the pipe previously did not have a system associated to it, this will create a new system.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The systemTypeId is not valid piping system type.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsDisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also