Pipe Set |
Updates the associated system type for the pipe.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- systemTypeId ElementId
- The ElementId of the piping system type.

Exception | Condition |
---|---|
ArgumentException | The systemTypeId is not valid piping system type. |
ArgumentNullException | A non-optional argument was null |

If the pipe previously did not have a system associated to it, this will create a new system.