RebarShapeConstraintSegmentLength Constructor


Create a segment length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public RebarShapeConstraintSegmentLength(
	ElementId paramId,
	RebarShapeSegmentEndReferenceType refType0,
	RebarShapeSegmentEndReferenceType refType1
)
Visual Basic
Public Sub New ( _
	paramId As ElementId, _
	refType0 As RebarShapeSegmentEndReferenceType, _
	refType1 As RebarShapeSegmentEndReferenceType _
)
Visual C++
public:
RebarShapeConstraintSegmentLength(
	ElementId^ paramId, 
	RebarShapeSegmentEndReferenceType refType0, 
	RebarShapeSegmentEndReferenceType refType1
)

Parameters

paramId
Type: Autodesk.Revit.DBElementId
The Id of a Rebar Shape parameter.
refType0
Type: Autodesk.Revit.DB.StructureRebarShapeSegmentEndReferenceType
Choose between two possibilities for the first reference of the length constraint.
refType1
Type: Autodesk.Revit.DB.StructureRebarShapeSegmentEndReferenceType
Choose between two possibilities for the second reference of the length constraint.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException paramId is not a valid Element identifier.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also