RebarShapeConstraintSegmentLength Constructor


Rebar Shape Constraint Segment Length Constructor

Create a segment length constraint.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public RebarShapeConstraintSegmentLength(
	ElementId paramId,
	RebarShapeSegmentEndReferenceType refType0,
	RebarShapeSegmentEndReferenceType refType1
)

Parameters

paramId ElementId
The Id of a Rebar Shape parameter.
refType0 RebarShapeSegmentEndReferenceType
Choose between two possibilities for the first reference of the length constraint.
refType1 RebarShapeSegmentEndReferenceType
Choose between two possibilities for the second reference of the length constraint.
Exceptions
Exception Condition
ArgumentException paramId is not a valid Element identifier.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also