Assigns override settings to a particular region within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- elementId
- Type: Autodesk.Revit.DBElementId
Id of the element to be overridden.
- newSettings
- Type: Autodesk.Revit.DB.PointCloudsPointCloudOverrideSettings
Override settings to be assigned.
- regionTag
- Type: SystemString
The tag identifying the particular region within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getRegions.
- doc
- Type: Autodesk.Revit.DBDocument
Document containing the element to be overridden.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown when supplied regionTag is not empty while doc is NULL |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The override settings are not valid. |