Point |
Assigns override settings to a particular region within a PointCloudInstance element.
Namespace: Autodesk.Revit.DB.PointClouds
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

public void SetPointCloudRegionOverrideSettings(
ElementId elementId,
PointCloudOverrideSettings newSettings,
string regionTag,
Document doc
)
Parameters
- elementId ElementId
- Id of the element to be overridden.
- newSettings PointCloudOverrideSettings
- Override settings to be assigned.
- regionTag String
- The tag identifying the particular region within the PointCloudInstance element. Tags can be obtained from PointCloudInstance via method getRegions.
- doc Document
- Document containing the element to be overridden.

Exception | Condition |
---|---|
ArgumentException | Thrown when supplied regionTag is not empty while doc is NULL |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | The override settings are not valid. |