TextNoteOptions Constructor (ElementId)


Constructs text options to create text of the given type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public TextNoteOptions(
	ElementId typeId
)
Visual Basic
Public Sub New ( _
	typeId As ElementId _
)
Visual C++
public:
TextNoteOptions(
	ElementId^ typeId
)

Parameters

typeId
Type: Autodesk.Revit.DBElementId
Id of a text type that defines the style of a text note.

Remarks

Except for the TypeId, all other properties of the option class will be populated with their respective default values.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also