Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pGeomArr
- Type: System.Collections.GenericIListGeometryObject
Shape of this object expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType
- Type: Autodesk.Revit.DBDirectShapeTargetViewType
Optional: set a view-specific shape representation that will be used in views of that type only. Passing DirectShapeTargetViewType::Default as view type will cause the default shape to be set.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | At least one member of pGeomArr does not satisfy DirectShape validation criteria. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |