SetShape Method (IList(GeometryObject), DirectShapeTargetViewType)


Direct Shape Set Shape(IList Geometry Object , Direct Shape Target View Type) Method

Builds the shape of this object from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetShape(
	IList<GeometryObject> pGeomArr,
	DirectShapeTargetViewType viewType
)

Parameters

pGeomArr IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve. For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
viewType DirectShapeTargetViewType
Optional: set a view-specific shape representation that will be used in views of that type only. Passing DirectShapeTargetViewType::Default as view type will cause the default shape to be set.
Exceptions
Exception Condition
ArgumentException At least one member of pGeomArr does not satisfy DirectShape validation criteria.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also