Set segment's start point or end point parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- targetRef
- Type: Autodesk.Revit.DBReference
Segment's reference whose parameter want to be set.
- endIdx
- Type: SystemInt32
Start point (=0) or end point (=1).
- param
- Type: SystemDouble
Value of parameter.
Return Value
true if operation success.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when regeneration fails. |