GetProjectionType Method


Gets the projection type of the CurveElement.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static CurveProjectionType GetProjectionType(
	CurveElement curveElem
)
Visual Basic
Public Shared Function GetProjectionType ( _
	curveElem As CurveElement _
) As CurveProjectionType
Visual C++
public:
static CurveProjectionType GetProjectionType(
	CurveElement^ curveElem
)

Parameters

curveElem
Type: Autodesk.Revit.DBCurveElement
The CurveElement.

Return Value

The projection type.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input CurveElement is not a CurveByPoints.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also