GetTriangle Method


Returns the triangle corresponding to the given index.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public TriangleInShellComponent GetTriangle(
	int triangleIndex
)
Visual Basic
Public Function GetTriangle ( _
	triangleIndex As Integer _
) As TriangleInShellComponent
Visual C++
public:
TriangleInShellComponent^ GetTriangle(
	int triangleIndex
)

Parameters

triangleIndex
Type: SystemInt32
The index of the triangle (between 0 and TriangleCount-1, inclusive).

Return Value

The triangle.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException triangleIndex is out of range.

See Also