Validates the custom field properties.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2024
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- customFieldProperties
- Type: Autodesk.Revit.DBICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.
Return Value
If the properties are valid, an empty string will be returned. If the properties are not valid, a non-empty string which describes the error will be returned.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | Can't validate the properties of a CustomFieldData of a SchedulableField (which is not added to a schedule). |