ValidateCustomFieldProperties Method


Custom Field Data Validate Custom Field Properties Method

Validates the custom field properties.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string ValidateCustomFieldProperties(
	ICustomFieldProperties customFieldProperties
)

Parameters

customFieldProperties ICustomFieldProperties
An instance of ICustomFieldProperties which represents the properties of this field.

Return Value

String
If the properties are valid, an empty string will be returned. If the properties are not valid, a non-empty string which describes the error will be returned.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
InvalidOperationException Can't validate the properties of a CustomFieldData of a SchedulableField (which is not added to a schedule).
See Also