GetFrameAzimuth Method


Identifies the azimuth of the sun (angle in radians) for a specific frame.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public double GetFrameAzimuth(
	double frame
)
Visual Basic
Public Function GetFrameAzimuth ( _
	frame As Double _
) As Double
Visual C++
public:
double GetFrameAzimuth(
	double frame
)

Parameters

frame
Type: SystemDouble
Frame for which time is requested

Return Value

Azimuth angle (radians). This is measured counterclockwise from the X axis (East direction). Note that this is a different frame of reference than is used by Revit for the Lighting Study Azimuth value.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException the frame value frame is not valid.

See Also