Sun |
Identifies the azimuth of the sun (angle in radians) for a specific frame.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- frame Double
- Frame for which time is requested
Return Value
DoubleAzimuth angle (radians). This is measured counterclockwise from the X axis (East direction). Note that this is a different frame of reference than is used by Revit for the Lighting Study Azimuth value.

Exception | Condition |
---|---|
ArgumentException | the frame value frame is not valid. |