ExternalResourceLoadData Class


This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public class ExternalResourceLoadData : IDisposable
Visual Basic
Public Class ExternalResourceLoadData _
	Implements IDisposable
Visual C++
public ref class ExternalResourceLoadData : IDisposable

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBExternalResourceLoadData

See Also