ExternalResourceLoadData Class


External Resource Load Data Class

This class contains the input and output data resulting from invoking an IExternalResourceServer's LoadResource method.

After the call to LoadResource, the resulting ExternalResourceLoadData will be passed into IExternalResourceServer.HandleLoadResourceResults() so that appropriate UI can be displayed.

Server providers can inspect the ExternalResourceLoadData to get an ExternalResourceLoadContent object of the subclass appropriate to the external resource. The class also contains a copy of the ExternalResourceReference, and information about the context of the load operation.

Inheritance Hierarchy
System Object
Autodesk.Revit.DB ExternalResourceLoadData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ExternalResourceLoadData : IDisposable

The ExternalResourceLoadData type exposes the following members.

Properties
Name Description
Public property ErrorsReported Indicates whether the IExternalResourceUIServer has reported errors for this ExternalResourceLoadData. This value can be set by the IExternalResourceUIServer in HandleLoadResourceResults().
Public property ExternalResourceType The ExternalResourceType for which Revit is requesting data from the server.
Public property IsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public property LoadStatus The success or failure status of the load attempt.
Top
Methods
Name Description
Public method Dispose Releases all resources used by the ExternalResourceLoadData
Public method GetExternalResourceReference Returns the ExternalResourceReference that identifies which resource should be loaded.
Public method GetLoadContent Returns the ExternalResourceLoadContent resulting from this load operation.
Public method GetLoadContext Returns an object containing information about the context of the load operation.
Public method GetLoadRequestId Returns the load operation GUID.
Top
See Also