NewCurtainSystem2 Method


Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public ICollection<ElementId> NewCurtainSystem2(
	ReferenceArray faces,
	CurtainSystemType curtainSystemType
)
Visual Basic
Public Function NewCurtainSystem2 ( _
	faces As ReferenceArray, _
	curtainSystemType As CurtainSystemType _
) As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ NewCurtainSystem2(
	ReferenceArray^ faces, 
	CurtainSystemType^ curtainSystemType
)

Parameters

faces
Type: Autodesk.Revit.DBReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType
Type: Autodesk.Revit.DBCurtainSystemType
The Type of CurtainSystem to be created.

Return Value

A set of ElementIds of CurtainSystems will be returned when the operation succeeds.

Remarks

The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown in following cases: The input argument faces or curtainSystemType is a null reference (Nothing in Visual Basic). The size of faces is zero.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.
Autodesk.Revit.ExceptionsArgumentExceptionThrown if the curtain system type does not exist in the given document.

See Also