NewCurtainSystem2 Method


Document New Curtain System 2 Method

Creates a new CurtainSystem element from a set of face references.

Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public ICollection<ElementId> NewCurtainSystem2(
	ReferenceArray faces,
	CurtainSystemType curtainSystemType
)

Parameters

faces ReferenceArray
The faces new CurtainSystem will be created on.
curtainSystemType CurtainSystemType
The Type of CurtainSystem to be created.

Return Value

ICollection ElementId
A set of ElementIds of CurtainSystems will be returned when the operation succeeds.
Exceptions
Exception Condition
ArgumentNullException Thrown in following cases: The input argument faces or curtainSystemType is . The size of faces is zero.
InvalidOperationException Thrown when the CurtainSystem cannot be created, for example, the input faces don't belong to same mass or generic model. Or regenerate fails.
ArgumentException Thrown if the curtain system type does not exist in the given document.
Remarks
The faces can belong to different masses or generic models. The number of CurtainSystems will be equal to the number of masses and generic models.
See Also