AddReferences Method


Adds references to the connection. All references should be of applicable category.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddReferences(
	Document document,
	IList<Reference> picks
)
Visual Basic
Public Sub AddReferences ( _
	document As Document, _
	picks As IList(Of Reference) _
)
Visual C++
public:
void AddReferences(
	Document^ document, 
	IList<Reference^>^ picks
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
picks
Type: System.Collections.GenericIListReference
The array containing picks of input elements to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException One or more picks was not permitted to be add to the connection. -or- One or more picks was not permitted to be added to the connection. Picks should not be duplicated.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also