AddReferences Method


Structural Connection Handler Add References Method

Adds references to the connection. All references should be of applicable category.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void AddReferences(
	Document document,
	IList<Reference> picks
)

Parameters

document Document
The document.
picks IList Reference
The array containing picks of input elements to be added.
Exceptions
Exception Condition
ArgumentException One or more picks was not permitted to be add to the connection. -or- One or more picks was not permitted to be added to the connection. Picks should not be duplicated.
ArgumentNullException A non-optional argument was null
See Also