RemoveWallSweep Method


Removes a single sweep or reveal from the compound structure.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public void RemoveWallSweep(
	WallSweepType wallSweepType,
	int id
)
Visual Basic
Public Sub RemoveWallSweep ( _
	wallSweepType As WallSweepType, _
	id As Integer _
)
Visual C++
public:
void RemoveWallSweep(
	WallSweepType wallSweepType, 
	int id
)

Parameters

wallSweepType
Type: Autodesk.Revit.DBWallSweepType
The type of a wall sweep.
id
Type: SystemInt32
The id of the sweep or reveal to remove.

Remarks

No validation of input arguments is performed. If no reveal or sweep has the specified id, no action is performed.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This operation is valid only for vertically compound structures.

See Also