Determines whether the given element represents an external file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- aDoc
- Type: Autodesk.Revit.DBDocument
A Revit Document.
- elemId
- Type: Autodesk.Revit.DBElementId
The element to be checked for an external file reference.
Return Value
True if the given element represents an external file; false otherwise.Remarks
CAD imports are not external file references, as their data is brought fully into Revit. No connection is maintained to the original file.
A link may be an external resource without being an external file.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element elemId does not exist in the document |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |