External |
Determines whether the given element represents an external file.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- aDoc Document
- A Revit Document.
- elemId ElementId
- The element to be checked for an external file reference.
Return Value
BooleanTrue if the given element represents an external file; false otherwise.

Exception | Condition |
---|---|
ArgumentException | The element elemId does not exist in the document |
ArgumentNullException | A non-optional argument was null |

CAD imports are not external file references, as their data is brought fully into Revit. No connection is maintained to the original file.
A link may be an external resource without being an external file.