Creates a free form rebar that will be unconstrained. Constraints can't be added later to this rebar.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2018
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- doc
- Type: Autodesk.Revit.DBDocument
A document.
- barType
- Type: Autodesk.Revit.DB.StructureRebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
- host
- Type: Autodesk.Revit.DBElement
The element to which the rebar belongs. The element must support rebar hosting.
- curves
- Type: System.Collections.GenericIListIListCurve
Each array of curves represent a bar in the set.
- error
- Type: Autodesk.Revit.DB.StructureRebarFreeFormValidationResult%
Will be Success if everything is ok, otherwise the failure reason.
Return Value
The newly created free form Rebar Instance.Remarks
This function can fail due to following reasons:
- One or more of the input curves was null.
- One or more of the input curves was unbounded.
- Curves doesn't form a valid curve loop, it forms 0, 2 or more curve loops.
- A rebar constructed from curves can't be bent according to the bending radius.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | host is not a valid rebar host. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |