CreateFreeForm Method (Document, RebarBarType, Element, IList(IList(Curve)), RebarFreeFormValidationResult)


Rebar Create Free Form(Document, Rebar Bar Type, Element, IList IList Curve , Rebar Free Form Validation Result ) Method

Creates a free form rebar that will be unconstrained. Constraints can't be added later to this rebar.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static Rebar CreateFreeForm(
	Document doc,
	RebarBarType barType,
	Element host,
	IList<IList<Curve>> curves,
	out RebarFreeFormValidationResult error
)

Parameters

doc Document
A document.
barType RebarBarType
A RebarBarType element that defines bar diameter, bend radius and material of the rebar.
host Element
The element to which the rebar belongs. The element must support rebar hosting.
curves IList IList Curve
Each array of curves represent a bar in the set.
error RebarFreeFormValidationResult
Will be Success if everything is ok, otherwise the failure reason.

Return Value

Rebar
The newly created free form Rebar Instance.
Exceptions
Exception Condition
ArgumentException host is not a valid rebar host.
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Remarks
The created rebar will have curves.Count bars. The layout will be Single if curves.Count is 1, otherwise will be Fixed Number and will not be changeable. Setting a new list of curves will only change the number of bars in set.

This function can fail due to following reasons:

  • One or more of the input curves was null.
  • One or more of the input curves was unbounded.
  • Curves doesn't form a valid curve loop, it forms 0, 2 or more curve loops.
  • A rebar constructed from curves can't be bent according to the bending radius.
See Also