GetRuleDescription Method (PerformanceAdviserRuleId)


Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public string GetRuleDescription(
	PerformanceAdviserRuleId id
)
Visual Basic
Public Function GetRuleDescription ( _
	id As PerformanceAdviserRuleId _
) As String
Visual C++
public:
String^ GetRuleDescription(
	PerformanceAdviserRuleId^ id
)

Parameters

id
Type: Autodesk.Revit.DBPerformanceAdviserRuleId
The rule id to get information for.

Return Value

The description of the rule.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also