GetRuleDescription Method (PerformanceAdviserRuleId)


Performance Adviser Get Rule Description(Performance Adviser Rule Id) Method

Retrieves the description of the rule.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public string GetRuleDescription(
	PerformanceAdviserRuleId id
)

Parameters

id PerformanceAdviserRuleId
The rule id to get information for.

Return Value

String
The description of the rule.
Exceptions
Exception Condition
ArgumentNullException A non-optional argument was null
See Also