Replaces all sorting/grouping fields in this ScheduleDefinition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- sortGroupFields
- Type: System.Collections.GenericIListScheduleSortGroupField
The new list of sorting/grouping fields.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The resulting sorting/grouping field count would be greater than 4. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field cannot be used for sorting/grouping. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |