SetSortGroupFields Method


Schedule Definition Set Sort Group Fields Method

Replaces all sorting/grouping fields in this ScheduleDefinition.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSortGroupFields(
	IList<ScheduleSortGroupField> sortGroupFields
)

Parameters

sortGroupFields IList ScheduleSortGroupField
The new list of sorting/grouping fields.
Exceptions
Exception Condition
ArgumentException The resulting sorting/grouping field count would be greater than 4. -or- A field ID is not the ID of a field in this ScheduleDefinition. -or- A field cannot be used for sorting/grouping.
ArgumentNullException A non-optional argument was null
See Also