CustomInitialColor Constructor (Double)


Creates a custom initial color set to the given color

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public CustomInitialColor(
	double temperature
)
Visual Basic
Public Sub New ( _
	temperature As Double _
)
Visual C++
public:
CustomInitialColor(
	double temperature
)

Parameters

temperature
Type: SystemDouble
The color temperature in Kelvin as a numerical value between 1800 and 20000

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException The color temperature is not valid because it is not in the range of 1800 to 20000.

See Also