Create a bunch of wires for the electrical system.
Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DBView
The view in which the wire is to be visible.
- wiringType
- Type: Autodesk.Revit.DB.ElectricalWiringType
Specify the wiring type (Arc or Chamfer) that is to be applied to all newly created wires.
Return Value
New created wiresExceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This method can only be used to create a bunch of wires according to specific pairs of elements, so if there exists a a null reference (Nothing in Visual Basic) element in any pair of familyInstancePairs, the exception will be thrown. |