IsCompatibleWith Method


Check whether the service is broadly interchangable with another one without affecting part geometry. The services must have the same fabrication system template and specification.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public bool IsCompatibleWith(
	FabricationService otherService
)
Visual Basic
Public Function IsCompatibleWith ( _
	otherService As FabricationService _
) As Boolean
Visual C++
public:
bool IsCompatibleWith(
	FabricationService^ otherService
)

Parameters

otherService
Type: Autodesk.Revit.DBFabricationService

Return Value

Returns true if the services are compatible.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also