Determines whether an element has any repeating reference sources that can be used when creating component repeaters.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document that contains the element.
- elementId
- Type: Autodesk.Revit.DBElementId
The id of the element.
Return Value
True if the element has any repeating reference sources.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element elementId does not exist in the document |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |