HasRepeatingReferenceSource Method


Repeating Reference Source Has Repeating Reference Source Method

Determines whether an element has any repeating reference sources that can be used when creating component repeaters.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static bool HasRepeatingReferenceSource(
	Document document,
	ElementId elementId
)

Parameters

document Document
The document that contains the element.
elementId ElementId
The id of the element.

Return Value

Boolean
True if the element has any repeating reference sources.
Exceptions
Exception Condition
ArgumentException The element elementId does not exist in the document
ArgumentNullException A non-optional argument was null
See Also