Sets the offset distance between the constrained RebarConstrainedHandle and its target Rebar handle surface.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020.1
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- distanceToTargetRebar
- Type: SystemDouble
The distance is given as an offset value, the sign of which depends on the target bar handle direction.
Remarks
Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | The given value for distanceToTargetRebar must be no more than 30000 feet in absolute value. |
Autodesk.Revit.ExceptionsInvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar.' -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |