Rebar |
Sets the offset distance between the constrained RebarConstrainedHandle and its target Rebar handle surface.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)

Parameters
- distanceToTargetRebar Double
- The distance is given as an offset value, the sign of which depends on the target bar handle direction.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | The given value for distanceToTargetRebar must be no more than 30000 feet in absolute value. |
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'ToOtherRebar'. -or- The RebarTargetConstraintType is 'HookBend' or 'BarBend'. |

Throws exception if the constraint is not to other rebar or if the target constraint is to bar bend or hook bend.